Performance issue affecting Carbon Ledger
Incident Report for CarbonTrail
Resolved
This incident has been resolved.
Posted Nov 12, 2024 - 19:35 UTC
Investigating
We are currently investigating this issue.
Posted Nov 12, 2024 - 00:39 UTC
This incident affected: Web Applications (Measure Application).